summaryrefslogtreecommitdiff
path: root/gst-vocschnipselssink/src/Makefile.am
diff options
context:
space:
mode:
authorMaZderMind <github@mazdermind.de>2014-07-28 22:58:42 +0200
committerMaZderMind <github@mazdermind.de>2014-07-28 22:58:42 +0200
commitbdbe54415b5083626ce911a6ad5ff2345d64a3d1 (patch)
treee08ddb1aacb4c836c652c62d66440fbeecd6ad90 /gst-vocschnipselssink/src/Makefile.am
parentb758723fe3266e91d0427c3367d0753a7663a514 (diff)
basic schnipsling in gst-c plugin, mostly copied from multifilesink
Diffstat (limited to 'gst-vocschnipselssink/src/Makefile.am')
-rw-r--r--gst-vocschnipselssink/src/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gst-vocschnipselssink/src/Makefile.am b/gst-vocschnipselssink/src/Makefile.am
new file mode 100644
index 0000000..ca42aa0
--- /dev/null
+++ b/gst-vocschnipselssink/src/Makefile.am
@@ -0,0 +1,26 @@
+# Note: plugindir is set in configure
+
+##############################################################################
+# TODO: change libgstplugin.la to something else, e.g. libmysomething.la #
+##############################################################################
+plugin_LTLIBRARIES = libgstvocschnipselsink.la
+
+##############################################################################
+# TODO: for the next set of variables, name the prefix if you named the .la, #
+# e.g. libmysomething.la => libmysomething_la_SOURCES #
+# libmysomething_la_CFLAGS #
+# libmysomething_la_LIBADD #
+# libmysomething_la_LDFLAGS #
+##############################################################################
+
+# sources used to compile this plug-in
+libgstvocschnipselsink_la_SOURCES = gstvocschnipselsink.c gstvocschnipselsink.h
+
+# compiler and linker flags used to compile this plugin, set in configure.ac
+libgstvocschnipselsink_la_CFLAGS = $(GST_CFLAGS)
+libgstvocschnipselsink_la_LIBADD = $(GST_LIBS)
+libgstvocschnipselsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstvocschnipselsink_la_LIBTOOLFLAGS = --tag=disable-static
+
+# headers we need but don't want installed
+noinst_HEADERS = gstvocschnipselsink.h